Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.
Get email notifications whenever Seequent creates, updates or resolves an incident.
Get text message notifications whenever Seequent creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
The AWS North Virginia region issue has been resolved. Services including MX Deposit and the Evo Web Interface are now operating normally. We’ll continue to monitor for stability.
Posted Oct 21, 2025 - 16:48 NZDT
Update
AWS North Virginia region issues are still on-going. We are also experiencing service degradation affecting Evo Web Interface. We are monitoring AWS progress and will update here once they have resolved their issue.
Posted Oct 21, 2025 - 05:13 NZDT
Monitoring
Due to the on-going AWS North Virginia region issues, we are experiencing service degradation affecting MX Deposit. We are monitoring AWS progress and will update here once they have resolved their issue.
Posted Oct 21, 2025 - 03:16 NZDT
This incident affected: MX Deposit and Evo (Evo Web Application).