Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Evo web application inaccessible

Incident Report for Seequent

Resolved

The issue has been resolved and remains stable. Thank you for your cooperation.
Posted Dec 04, 2025 - 05:19 NZDT

Monitoring

Our upstream provider is rolling out a fix for the issue, we are seeing an improvement on service availability. We will update again when we reach full recovery.
Posted Dec 04, 2025 - 04:15 NZDT

Update

We have discovered that our identity provider is experiencing issues and are actively investigating the issue.
We will continue to share updates as they progress toward a resolution. Thank you for your patience.
Posted Dec 04, 2025 - 03:44 NZDT

Update

We have discovered that our identity provider is experiencing issues and are actively investigating the issue.
We will continue to share updates as they progress toward a resolution. Thank you for your patience.
Posted Dec 04, 2025 - 03:42 NZDT

Investigating

We're aware of an issue where logins are failing for Seequent Evo Web Applications.
Our team is actively investigating and working to resolve the problem. We'll provide further updates as soon as more information becomes available.
Posted Dec 04, 2025 - 03:16 NZDT
This incident affected: Evo (Driver, BlockSync, Evo Web Application) and Leapfrog Desktop, Oasis Montaj Desktop.