Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Intermittent login issues for Evo products

Incident Report for Seequent

Resolved

The upstream authentication issue has been resolved, we will continue to monitor.
Posted Nov 01, 2025 - 19:59 NZDT

Identified

Our login service provider is experiencing degraded performance resulting in intermittent login errors for Evo services. Our provider is investigating.
Posted Nov 01, 2025 - 19:01 NZDT
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).