Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.
Get email notifications whenever Seequent creates, updates or resolves an incident.
Get text message notifications whenever Seequent creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
The issue has been resolved and remains stable. Thank you for your cooperation.
Posted Dec 02, 2025 - 05:41 NZDT
Monitoring
Our identity provider has seen improved performance and are closely monitoring the results.
Posted Dec 02, 2025 - 04:32 NZDT
Update
Our identity provider is still actively working into the issue and will provide an update as soon as new information becomes available. We appreciate your patience.
Posted Dec 02, 2025 - 04:01 NZDT
Update
Our identity provider is still actively working through the problem space and progressing toward resolution. We will continue to provide updates as more information becomes available. Thank you for your patience.
Posted Dec 02, 2025 - 02:28 NZDT
Update
Our authentication provider is actively investigating the issue. We will continue to share updates as they progress toward a resolution. Thank you for your patience.
Posted Dec 02, 2025 - 01:11 NZDT
Investigating
We are currently investigating an upstream issue preventing users from being able to log into some Seequent Evo products
Posted Dec 01, 2025 - 23:27 NZDT
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).