Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.
Get email notifications whenever Seequent creates, updates or resolves an incident.
Get text message notifications whenever Seequent creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2025 - 00:00 NZDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 14, 2025 - 15:41 NZDT
Scheduled
Scheduled - BlockSync will undergo essential upgrades over the weekend of 25-26 October, based on the local time zone of your regional BlockSync instance. Maintenance will be performed region by region to minimize impact, with expected downtime per region typically under one hour. The platform may be intermittently unavailable during this time.
Thank you for your understanding as we work to improve performance and reliability.
Posted Oct 14, 2025 - 12:07 NZDT
This scheduled maintenance affected: Evo (BlockSync).