Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Seequent.com Informational Website inaccessible

Incident Report for Seequent

Resolved

We have identified and resolved the issue impacting the seequent.com website.
We are sorry for any inconvenience this may have caused.
Posted Jan 05, 2026 - 12:31 NZDT

Investigating

We are currently experiencing an issue affecting the main page of www.seequent.com, which is unresponsive due to an upstream hosting problem. Our team is actively investigating this with our hosting provider.
Posted Jan 05, 2026 - 12:11 NZDT
This incident affected: Seequent.com Website.