Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Users may be seeing intermittent issues logging into Evo within the U.S

Incident Report for Seequent

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 03:33 NZST

Monitoring

We are closely monitoring the performance. Thanks for your patience.
Posted Jul 31, 2026 - 03:27 NZST

Update

Our authentication provider has identified the issue, and the fix has been implemented. we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 31, 2026 - 03:26 NZST

Investigating

Investigating - Our authentication provider is investigating the root cause, we will provide updates as they are available.
Posted Jul 31, 2026 - 02:59 NZST
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).