Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Evo Login Issues Impacting U.S. Users

Incident Report for Seequent

Resolved

This incident has been resolved. Thank you for your patience.
Posted Aug 11, 2026 - 02:58 NZST

Investigating

We're currently investigating an issue with our upstream authentication provider impacting the US region. As a result, some users may experience difficulty logging in.

Our team is actively working to identify the root cause and restore normal service. We'll share an update as soon as we have more information.

We apologize for any inconvenience and thank you for your patience.
Posted Aug 11, 2026 - 02:51 NZST
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).