Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Users may be seeing intermittent issues logging into Evo within the U.S.

Incident Report for Seequent

Resolved

The underlying fault has been rectified, intermittent login issues to Evo within the U.S. have been resolved.
Posted Nov 04, 2025 - 14:56 NZDT

Investigating

Our authentication provider is investigating the root cause, we will provide updates as they are available.
Posted Nov 04, 2025 - 14:22 NZDT
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).