Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Aarhus Software Availability Degraded

Incident Report for Seequent

Resolved

This has now been resolved.
Posted Jan 07, 2026 - 04:21 NZDT

Identified

Due to a network issue, perpetual licenses for some Aarhus Software are not currently functioning as intended. This may result in availability issues for some users. We have identified the root cause and are working to remediate.
Posted Jan 07, 2026 - 01:38 NZDT
This incident affected: Aarhus GeoSoftware (Workbench, Spia, Res2D, Res3D).