Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

BlockSync is currently unavailable

Incident Report for Seequent

Resolved

This incident has now been resolved. Thank you for your patience.
Posted May 05, 2026 - 12:17 NZST

Identified

The root cause has been identified, and our team is actively working on a resolution.
Posted May 05, 2026 - 10:47 NZST

Investigating

Our teams are actively working to restore functionality and will provide further updates as progress is made.
Posted May 05, 2026 - 10:26 NZST
This incident affected: Evo (BlockSync).