Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.
We have now seen full recovery across all Evo services.
Posted Oct 30, 2025 - 12:07 NZDT
Monitoring
Our upstream provider is rolling out a fix for the issue, we are seeing an improvement on service availability. We will update again when we reach full recovery.
Posted Oct 30, 2025 - 09:27 NZDT
Update
An upstream issue with a service provider is causing intermittent connectivity and authentication issues with Evo Services. We are working with the provider and will provide updates when available.
Posted Oct 30, 2025 - 09:02 NZDT
Update
All functionality has been restored for all impacted services; we will continue to monitor all components. Thank you for your patience.
Posted Oct 30, 2025 - 08:54 NZDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 08:26 NZDT
Identified
The source of the disruption has been traced to an underlying global issue with an upstream cloud provider. The provider is working on a resolution to restore services. Seequent Evo products are encountering degraded availability due to this issue.
Posted Oct 30, 2025 - 07:49 NZDT
Investigating
We are currently investigating an upstream issue preventing users from being able to log into some Seequent products. We are investigating.
Posted Oct 30, 2025 - 05:22 NZDT
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application) and Central, MX Deposit.