Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.
Get email notifications whenever Seequent creates, updates or resolves an incident.
Get text message notifications whenever Seequent creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
We have identified the root cause of the intermittent login failures and degraded response times affecting Evo services in the US region. The issue was traced to instability in our Identity Management System (IMS). A fix has been applied, and we are currently monitoring the system to ensure full recovery and stability.
Posted Oct 31, 2025 - 02:49 NZDT
Identified
We have identified the root cause of the intermittent login failures and degraded response times affecting Evo services in the US region. The issue originates from our Identity Management System (IMS), which is currently experiencing instability. Our engineering team is actively working on mitigation and a permanent fix.
Posted Oct 31, 2025 - 02:22 NZDT
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).