Seequent Cloud Services Status

Welcome to Seequent cloud health dashboard.
Follow the operational status of our products, key features and services.
Issues and interruptions are listed on this page.

Users may be seeing intermittent issue logging into Evo within the Europe Regions

Incident Report for Seequent

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 01:05 NZST

Investigating

Our authentication provider is currently investigating an issue with IMS in the Europe Region. Some users may be having trouble authenticating their login.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Aug 04, 2026 - 00:34 NZST
This incident affected: Evo (Geoscience Object API, Driver, BlockSync, Files, Colormap API, Workspaces, Task API, Evo Web Application).